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About This Guide 
This guide provides how-to and troubleshooting information for users of  
Agile Systems' DPFlex brushless DC motor drive. 

 

Who This Guide is for 
This guide is intended primarily for designers of sensorless brushless DC motor 
applications who need the breakthrough performance and application design simplicity 
offered by DPFlex. 

 
This guide assumes the reader is familiar with the following topics: 

• The design and function of brushless DC motor applications 

• How to use Microsoft Windows 

How to Use This Guide 
This guide includes the following topics: 
 

• Chapter 1: “Getting Started with DPFlex” describes how to get going quickly 
with DPFlex. 

• Chapter 2: “Introducing DPFlex” provides an overview of DPFlex's features and 
benefits, and how you develop and deploy DPFlex applications. 

• Chapter 3: “Designing DPFlex Applications” provides the information you need 
to design DPFlex applications, including electrical and mechanical specifications. 

• Chapter 4: “Setting Up DPFlex” describes how to install DP.D, the software you 
use to configure DPFlex. It also describes how to connect power, a brushless DC 
motor, and a development computer to the DPFlex drive. 

• Chapter 5: “Creating DPFlex Applications” describes how to configure DPFlex 
for a motor. 
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Chapter 1 Getting Started with DPFlex 
 
Welcome to DPFlex. 
  

 
 
 
To learn what DPFlex can do for you, see Chapter 2: “Introducing DPFlex”. 

 

To see detailed specifications for DPFlex, see Chapter 3: “Designing DPFlex Applications”. 

 

To set up the DPFlex hardware and software, see Chapter 4: “Setting Up DPFlex”. 

 

To develop a DPFlex application, see Chapter 5: “Creating DPFlex Applications”. 
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Chapter 2 Introducing DPFlex 
 
This chapter provides an overview of DPFlex: its features, function, and specifications.  
 
For details, see the following topics: 
• “What is DPFlex?” on page 9 

• “DPFlex Components” on page 11 

• “How do I use DPFlex?” on page 12 
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What is DPFlex? 
 
Agile Systems' DPFlex™ provides sensorless control of brushless DC motors at 
performance levels that exceed those of conventional Hall commutated drives. DPFlex 
detects motor rotor position at motor stand still through an innovative algorithm based on 
motor phase-inductance measurement. You can integrate DPFlex into the bell end of the 
motor or mount it externally. 
  

 
Figure 2-1. The DPFlex drive 
 
DPFlex has the following features: 

• Enables a brushless DC motor to provide controlled torque or speed without using 
sensors 

• One non-isolated analog input to adjust the torque or speed 

• One non-isolated digital input to select the direction of motor rotation 

• One non-isolated digital input to enable or disable the motor 

• One non-isolated digital output 

• Over-temperature and over-current protection 

• Auto-start programming function 

• Versions for 30 A, 15 A or 10 A motors 
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Agile Systems' DP.D software for Microsoft® Windows® 2000/XP/Vista enables you to 
tune, configure, and program the drive. It provides the following features: 

• Motor set-up and configuration tools 

• Inputs set-up and configuration tools 

• Motor verification and performance analysis tools 

• Integrated online help 

DPFlex is suitable for a wide range of applications, including control of fans, pumps, 
compressors, centrifuges, drills and mills, conveyors, office and medical equipment, 
automotive subsystems, and many others. 
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DPFlex Components 
The DPFlex product family includes the following components: 
• The DPFlex drive 
• The DP.D software for Microsoft Windows 2000/XP 
• Cables and connectors for connecting a DPFlex drive to power, motor, and  
• A personal computer 
• This user manual 
Note Agile Systems offers evaluation kits that contain all the DPFlex components you 
need to design and test your application. 
Table 2-1. DPFlex Evaluation Kits  

DPFlex Drive Maximum Ratings Part Number 

16 V / 30 A 11-F0012-30 

16 V / 15 A 11-F0012-15 

16 V / 10 A 11-F0012-10 

30 V / 30 A 11-F0024-30 

30 V / 15 A 11-F0024-15 

30 V / 10 A 11-F0024-10 
 

Table 2-2. DPFlex Evaluation Kit parts list  
Component Part Number 

DPFlex Drive 
16 V Maximum 

30A: 10-F0012-30 
15A: 10-F0012-15 
10A: 10-F0012-10 

DPFlex Drive 
30 V Maximum 

30A: 10-F0024-30 
15A: 10-F0024-15 
10A: 10-F0024-10 

USB to UART Communication Cable 10-0099 

USB A to B Communication Cable 40-0089 

Motor Cable 40-0106 

Power Cable 40-0105 

Kit Connection Instruction 07-0044 

DP.D CD 35-0028 

DPFlex User Manual 34-2109 

 
For pricing information, please contact Agile Systems.  
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How do I use DPFlex? 
There are two phases to using DPFlex: 

• Configuring DPFlex for the target motor 

• Deploying the configuration data to production DPFlex drives 

 

Configuring DPFlex 

There are two steps to configuring DPFlex: 

1. Set up DPFlex. 

• Install the DP.D software. 

• Connect the drive to the PC, a power supply, and a motor. 
For details, see Chapter 4: “Setting Up DPFlex”

2. Use DP.D to configure DPFlex. 

a. Configure the drive for the target motor. 

b. Tune the current and velocity loops. 

c. Save configuration parameters to a file. 

For details, see Chapter 5: “Creating DPFlex Applications”
 

Deploying DPFlex 

There are two steps to configuring a production DPFlex drive: 

1. Connect the deployment PC to the production drive. 

For details, see “Connecting DPFlex to a PC” on page 32

2. Use DP.D to download the configuration parameters from the PC to the production drive. 

For details, see “Deploying DPFlex Applications” on page 69
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Chapter 3 Designing DPFlex Applications 
 

This chapter provides the information you need to design applications for DPFlex. 
 
For details, see the following topics: 
• “Understanding Commutation and DPFlex” on page 14 

• “DPFlex Specifications” on page 18 

• “DPFlex Connectors” on page 21 

• “DPFlex Dimensions” on page 22 

• “DPFlex Safety” on page 23 

• “DPFlex Power Dissipation” on page 24 
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Understanding Commutation and DPFlex 
 

Controlling current in a motor to produce torque is called commutation. Torque in an 
electric motor is the interaction between two magnetic fields, one from a rotor and the 
other one from a stator. These two magnetic fields must move relative to each other to 
maintain torque. 
 
There are two ways to produce a moving magnetic field. One way is to apply AC current to 
stationary windings. The other is to change the physical path of DC current in a stator. A 
DC motor uses the latter approach to commutation. 
 
DPFlex changes the path of current in motor coils in the following manner. Electrical 
commutation is done using an external controller to change the current path. Current is 
directed through various wires in the stator creating a moving magnetic field. To control the 
paths for current, DPFlex uses a six-step sensorless method that relies on back 
electromotive force sensing. 

 
 

Six-step or Trapezoidal Commutation 

 
In this method, there are only two phases of the stator coils energized by the DC source. 
To complete one electrical cycle (360 degrees) for magnetic field rotation, every phase 
would be energized four times (two times in the positive polarity and the other two in the 
negative polarity). Because the transition from one step to the other is discrete, the 
waveform of the field is like a trapezoid. This method is simple and can be used for 
different types of BLDC motors. The simplicity and effectiveness of this method makes it 
an attractive choice for commutation even at high speed. BLDC motors are commutated in 
six steps every 60° during a full 360° electrical. Only two of the three coils are energized at 
any time. 
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Figure 3-1. Motor current and back-EMF waveforms 
 

Sensorless Six-step Commutation 

Once the shaft of the motor is spinning sufficiently fast, the induced speed voltage caused 
by the time varying magnetic flux linking the stator windings can be measured by the drive. 
The magnetic flux is produced from the permanent magnets contained in the rotor. It is 
possible to use this information to commutate the motor without any other form of position 
feedback. This is what is meant by the term sensorless: it is the absence of position 
feedback. 
For trapezoidal commutation, only two coils of the three motor coils are energized at any 
one time. The coils that are energized are the two that yield the maximum developed 
electromagnetic torque. For Y ('WYE') a connected motor, the third coil is off and the 
speed voltage can be sensed at its phase post. Each of the three coils is ON for 120 
electrical degrees and is then OFF for 60 electrical degrees. This pattern is repeated again 
and again every 180 electrical degrees with the current switching direction each 180 
segment. 
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The speed voltage induced in the OFF phase undergoes a polarity reversal during the time 
the phase is OFF. The bias voltage is the voltage of the neutral point of the WYE 
connection. Ideally, the drive should shut OFF a coil as the induced speed voltage across 
that coil is undergoing a polarity reversal. The coil should then be re-energized once the 
voltage has changed polarity and that coil can contribute to torque production. In order to 
do this, the controller samples the voltage of the OFF phase once the current in that phase 
has dropped to zero. Once it detects that the rotor flux is generating a speed voltage of the 
proper polarity, it shuts OFF the coil that is just beginning to go through this voltage 
reversal process and energizes the one that just finished this process. 
The drive uses a physical constant of the motor in order to assess when the time is 
appropriate. The motor constant related to the volts per rpm (Ke) of the motor is used to 
calculate how much flux there is per pole. By integrating the induced speed voltage in the 
OFF phase and waiting for the proper amount of flux to accumulate, the drive can 
commutate at the proper time. 
Since this is a motor constant, it is speed independent and it is applicable at all speeds at 
which the back EMF of the motor can be detected by the drive. 

 
Figure 3-2. Six step commutation sequence 

Special Considerations for Sensorless Commutation 

During the process of commutation, current in one phase must drop to zero and be 
transferred to the phase that is just coming ON. Because of the fact that the coils are not 
mutually coupled 100% and that each coil has its own leakage reactance, there will be a 
portion of time, albeit brief, where all three coils have current in them. During this period of 
time, an accurate back- EMF or speed voltage cannot be obtained from the voltage sense 
circuit on the controller. 
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Immediately after commutation, the drive will shut OFF the phase voltage and wait until it 
determines that an accurate back EMF signal can be obtained from the analog input 
dedicated to BEMF sensing in the OFF phase. 
It is only after this has been successfully detected that the drive will begin to use the 
measured speed voltage for commutation purposes. Since DPFlex itself monitors the 
speed voltage feedback and activates the back EMF sensing itself, there is no parameter 
associated with the coil-coil current transfer. 
 

Sensorless Startup 

As the back-EMF is proportional to speed a sensorless controller needs a means of finding 
the initial rotor position, in order to start the motor and accelerate it to sufficient speed to 
be able to detect the back-EMF voltage. Startup is undoubtedly the biggest hurdle any 
sensorless-control algorithm must overcome. Conventional methods drive a current 
through the motor windings, in order to force the motor rotor into a known position to 
ensure proper motor start. This can cause up to 180° of (2-pole) motor rotation opposite to 
the desired direction, adding to acceleration and startup time. The current required to 
orient the rotor depends on the inertial and frictional load of the motor. If the initial current 
to orient the motor is too high, there may be overshoot and ringing in the system. If the 
current is too low, the motor may not start at all. Such a system is not robust with respect 
to system load conditions. 
 
More advanced methods determine motor rotor position based on the motor-phase 
saturation inductance change. The drive generates 6 short, opposing current pulses that 
drive the motor phases into saturation. The drive calculates the motor rotor position based 
on the saturation inductance change in each phase. We refer to this procedure as the ping 
method. The motor rotor remains stationary during the initial ping period, because the 
current pulses are short and in opposing sequence. In most cases, the motor reaches 
sufficient speed before the next commutation-sector change for the back-EMF 
commutation algorithm to take over. In a few cases, usually if the load on the motor is 
extremely heavy, the ping process repeats while the motor rotates at low speeds below the 
back-EMF commutation threshold. This is possible, because the ping period time is 
negligible with respect to the time between sector transitions at low motor speeds. The 
ping method guarantees unidirectional motor start, which is independent of motor loading 
conditions. The system is robust with respect to system load conditions.
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DPFlex Specifications 
Table 3-1 below lists DPFlex's electrical specifications.  
 
Table 3-1. DPFlex Electrical Specifications 

Feature Description Min Typical Max Units 

15 24 30 Volts Supply voltage  

8 12 16 Volts 

Motor type Brushless AC/DC 
WYE connected 

 

Output Phase Current    30/15/10 Amps 

Motor phase-to-phase inductance   100  μHenry 
Motor time constant   150  μsec 
Trip temperature1    90 °C 
Digital Input2: motor  
direction and enable/disable 

 0  30 Volts 

Digital output3  0  30 Volts 

Analog input4 Single-ended 0  5 Volts 

Analog Input sampling frequency   100  Hz 

Input sampling frequency   20  KHz 

    Commutation type Six step back 
electromotive 
force based     

Commutation time  250   μsec 
    Diagnostics 400-point data 

logger     

    

    

Protections Over/under voltage 
Over phase current 
Over temperature 

    

Digital TX  115  Kbps USB-UART communications 

Digital RX  115  Kbps 

                                                 
1 Refer to the power dissipation curve shown in Figure 3-8 to properly heat-sink the drive 
2 Digital inputs require isolation if connected to active circuitry. Refer to schematic shown Figure 3-3 & Figure 3-4. 
3 Refer to schematic shown in Figure 3-5 
4 Refer to schematic shown in Figure 3-6  
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Figure 3-3. Example of connecting passive circuitry to DPFlex's Enable Line (DI1) 

 
 
 

 
 

Figure 3-4. DPFlex's Digital Input2 (Motor Direction) circuitry 
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Figure 3-5. DPFlex's Digital output circuitry  
 

 
 
 

 
Figure 3-6. Example of connecting passive circuitry to DPFlex's analog input 
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DPFlex Connectors 
Table 3-2 below lists DPFlex's board connectors. 
 
Table 3-2. DPFlex Board Connectors 

Connector Type Pins 

Power Keystone Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75]) 

2 

Motor Keystone Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75]) 

3 

Enable Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75]) 

1 

Analog & Digital I/O JST (P/N #: SM06B-GHS-TB) 6 

USB-UART Communication JST (P/N #: SM04B-GHS-TB) 4 

 
For connector pinouts for DPFlex, see “Making Cables for DPFlex Drives” on page 32
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DPFlex Dimensions 
 
Figure 3-7 below shows the physical dimensions of the DPFlex. 
 
 

 
 
 

 
 
Figure 3-7. DPFlex dimensions (in mm) 
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DPFlex Safety 
To ensure safe operation of DPFlex, your application must meet the following 
requirements: 
 
 CAUTION Failure to comply with the requirements listed below may
 create an electrical hazard in your application. 

 
 

• Use two AWG 16 twisted (with one twist per cm) cables 3 ft  
[1 m] long to connect the DC power supply to DPFlex. 

• Use three AWG 16 twisted (with one twist per cm) cables 1 ft 
[.3 m] long to connect the motor to DPFlex. 

• Connect a fuse between the positive voltage from the DC 
power supply and pin J3 (B+) on DPFlex's power terminal. 
Size the fuse to 150% of DPFlex's rated current. 

• Spot ground the DPFlex drive itself. 
• Use a USB cable to connect the PC to the USB-UART adapter. 
• Heat sink the DPFlex drive, using the power dissipation curve 

shown in Figure 3-8 to guide the heat sink’s design. 
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DPFlex Power Dissipation 
DPFlex generates heat as its consumption of power increases. Use the graphs in 
Figure 3-8 and Figure 3-9 below to determine safe operation.  
 

 
Figure 3-8. DPFlex's power dissipation 
 
 
Note The dissipation curve was generated with balanced, 3-phase sinusoidal current at a 
100 Hz fundamental and a 20 KHz switching frequency. 
 

 
Figure 3-9. DPFlex's safe operating area 
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Chapter 4 Setting up DPFlex 
 

This chapter describes how to set up DPFlex so that you can configure it for a motor.  
 
For details, see the following topics: 
• “Installing the Software” on page 26 

• “Connecting the DPFlex Drive” on page 29 
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Installing the Software 
The software provided with the DPFlex drive includes DP.D, an application for Microsoft 
Windows that enables you to configure and monitor the drive, and a USB-to-serial driver 
that enables a PC to communicate with the drive over a USB port. 
For details about installing the DP.D software see the upcoming topics: 

Installation Requirements 

To install and run the DPFlex software, you need a personal computer that meets the 
following minimum requirements: 
• Windows 2000 with SP4 or Windows XP with SP2 

• A USB port or an RS-232 serial communication port capable of 115200 bps 

• 133 MHz or higher Pentium-compatible microprocessor 

• At least 64 megabytes (MB) RAM 

• 50 MB available storage 

• SVGA or higher resolution monitor.  

 
Note A personal computer equipped with more RAM or a faster microprocessor will 
provide significantly better performance. 
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Using the Installation CD 

The DPFlex software is packaged on a CD-ROM (part number 35-0028). 
 
To run the installation utility 
1. Insert the CD in your CDROM drive. 
2. Wait for the Install Application to run. 

 

 

 

3. If the installation utility does not automatically run, run the Setup.exe program in the 
root of the CD. 

 
 

To install DP.D 

1. In the installation utility, choose Install DP.D. 
The installation utility launches the DP.D installation wizard: 
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2. Follow the instructions in the wizard to install DP.D. 
Note DP.D requires an Open Database Connectivity driver to be installed on the PC. If you 
do not have one, you can install one by running the MDAC_TYP.EXE program in the 
MDAC2_8 directory on the CD. 

 
To install the USB-to-serial driver 
1. In the installation utility, choose Install USB-to-serial Driver. 

The installation utility launches the driver installation wizard: 

 

 
2. If you want to change where the driver is installed, choose Browse to select another 

location. 
3. Choose Install to install the driver or Cancel to abort the operation.  
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Connecting the DPFlex Drive 
To use the DPFlex drive in an application, you must connect it to power, and to a motor. 
To configure DPFlex and to monitor its performance, you must also connect it to a PC. 
 
For details, see the upcoming topics: 

DPFlex Safety 

To ensure safe operation of DPFlex, your application must meet the following 
requirements: 
 
 CAUTION Failure to comply with the requirements listed below may
 create an electrical hazard in your application. 

 
 

• Use two AWG 16 twisted (with one twist per cm) cables 3 ft  
[1 m] long to connect the DC power supply to DPFlex. 

• Use three AWG 16 twisted (with one twist per cm) cables 1 ft  
[.3 m] long to connect the motor to DPFlex. 

• Connect a fuse between the positive voltage from the DC  
power supply and pin J3 (B+) on DPFlex's power terminal.  
Size the fuse to 150% of DPFlex's rated current. 

• Spot ground the DPFlex drive itself. 
• Use a USB cable to connect the PC to the USB-UART adapter. 
• Heat sink the DPFlex drive, using the power dissipation curve  

shown in Figure 3-8 to guide the heat sink’s design. 
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Connecting DPFlex with the Cable Kit 

The easiest way to connect a DPFlex drive is to use cables offered by Agile Systems: 
• The DPFlex Power Cable (part number 40-0105) connects the drive to power. One 

end (fitted with Amp 8-520182-1) of the red wire in the cable connects to J3/B+ (the 
positive pin). One end (also fitted with Amp 8-520182-1) of the white wire in the cable 
connects to J4/B- (the ground pin). The other ends connect to the power supply. 

• The DPFlex Motor Cable (40-0106) connects the drive to a motor. One end (fitted with 
Amp 8-520182-1) of each of the red, white, and black wires in the cable connects to 
the motor pins (Motor Phase A: pin J5; Motor Phase B: pin J6; Motor Phase C: pin J7). 
The other ends connect to the corresponding motor phases. 

• The DPFlex USB to UART Communication Cable Kit (part number 10-0099) connects 
the drive to a USB port on a PC. It includes the following cables: 

o A 6-foot USB A to B Cable (part number 40-0098) 
o A USB-UART adapter cable (part number 40-0094) 

 
Note You can make your own cables. For details, see “Making Cables for DPFlex  
Drives” on page 32
 
As shown in Figure 4-1 on the next page, the DPFlex drive has three connectors. 
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UART Connector 

Analog & Digital Inputs 
connectors 

Power connector 
pins 

Motor connector 
pins 

Enable pin 

 

 

 

 

 

 

 

 

Figure 4-1. DPFlex connector locations 
 

To connect the device, see the upcoming procedures: 
 

Connecting DPFlex to a PC 

1. Plug one end of the USB A to B cable into the USB port of the USB-UART adapter 
cable. 
 

2. Plug the free end of the USB A to B cable into a USB port on the PC. 
Note If you did not install the USB-to-serial driver when you installed DP.D, the PC will 
launch a device driver install wizard when it detects the adapter cable. Use the wizard to 
install the driver from the driver directory on the DP.D CD. 
 

3. Plug the free end of the adapter cable into the serial communications connector on the 
DPFlex drive. 
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Connecting DPFlex to power 
1. Plug the power cable into DPFlex's power connector. 

2. Wire the other end of the power cable to your power supply, referring to their labels for pin 
number and signal name. 

 
 CAUTION Failure to connect a properly-rated fuse between DPFlex's high voltage 

 input (pin J5 on the power connector) and the power supply may create an  
 electrical hazard. Size the fuse to 150% of DPFlex's rated current. 

 
Connecting DPFlex to a motor 
1. Plug the motor cable into DPFlex's motor connector. 

2. Wire the other end of the motor cable to the motor. 

 

Making Cables for DPFlex Drives 

You can make your own cables for DPFlex as long as the following points are adhered to: 
• The signal cables for J1 must be less than 1m in length. 
• Drive dc power supply cables connected to J3/J4 should be made as short as possible 

and should be twisted together using 1 twist or more per cm. 
• Motor cables connected to J5/J6/J7 should be as short as possible and should be 

twisted together using 1 twist or more per cm. 
• An additional electrolytic capacitor placed as close as possible to the J3/J4 power 

connectors is recommended.  Rule of thumb sizing for this capacitor is 30uF per amp.  
Cables running to and from the added capacitor should follow the above cabling 
practices. 

• If extra capacitance is used, it is highly recommended that a pre-charge circuit be used 
to limit the inrush current required to charge this capacitance.  The limiting resistor 
should then be shorted out using a relay or some other appropriate means. 

 

The following tables list the pinouts and connector type for each connector on the drive.  
Figure 4-2 on the next page shows how external devices are connected to DPFlex. 

Note The serial communications connector on the drive uses TTL signals. If you want to 
communicate with the drive from a device using standard RS-232 signals, you must 
provide a means to convert the signal levels between the two devices.
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Figure 4-2. DPFlex connections 
  

Table 4-1. Analog & Digital I/O connector pinout [J1]  
(JST connector P/N #: SM06B-GHS-TB) 

Pin (Pin Name) Purpose 

J1.1 (A5V) Analog 5V 
J1.2 (AIN) Analog Input (0-5V DC) 
J1.3 (ACH) Analog Common 
J1.4 (DI1) or J8 (DI1) Digital Input 1 [motor enable/disable] (Referenced to J4/B-) 
J1.5 (DI2) Digital Input 2 [motor direction] (Referenced to J4/B-) 
J1.6 (D0) Digital Output (Referenced to J4/B-) 

 
Table 4-2. Serial communication connector pinout [J2] 

(JST connector P/N #: SM04B-GHS-TB) 
Pin (Pin Name) Purpose 

J2.1 (GND) Communication Ground 
J2.2 (TX) Transmit 
J2.3 (5V) Communication 5V 
J2.4 (RX) Receive 

 
Table 4-3. Power connector pins  

(Keystone Terminals P/N #: 4907) 
Pin (Pin Name) Purpose 

J3 (B+) (+) DC Voltage 
J4 (B-) (-) DC Voltage  

 
Table 4-4. Motor connector pins  

(Keystone Terminals P/N #: 4907) 
Pin (Pin Name) Purpose 

J5 (APH) A Motor Phase 
J6 (BPH) B Motor Phase 
J7 (CPH) C Motor Phase 
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Chapter 5 Creating DPFlex Applications 
 

This chapter describes how to develop and deploy a DPFlex application: how to configure 
it for a motor, how to check the analog and digital inputs, how to set motor performance 
parameters, and how to check application performance.  
 
For details, see the following topics: 
 
• “Developing DPFlex Applications” on page 35 

• “Using DP.D” on page 36 

• “Creating and Managing Configurations” on page 46 

• “Configuring DPFlex” on page 50 

• “Tuning the Current Loop” on page 53 

• “Tuning the Velocity Loop” on page 59 

• “Viewing DPFlex Inputs” on page 65 

• “Viewing and Configuring Faults” on page 66 

• “Deploying DPFlex Applications” on page 68 
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Developing DPFlex Applications 
Once you have installed DP.D and connected a motor and power to DPFlex, you can start 
developing your application. 
 
To develop a DPFlex application 
1. Create a configuration. 

A configuration stores controller and motor settings, and other application parameters. 
DP.D enables you to create and store multiple configurations. 
For details, see “Creating and Managing Configurations” on page 46 

 

2. Configure DPFlex for the motor you want to use in the application. 
For details, see “Configuring DPFlex” on page 50 

 

3. Tune the current loop for the application. 
For details, see “Tuning the Current Loop” on page 53 
 

4. Tune the velocity loop for the application. 
For details, see “Tuning the Velocity Loop” on page 59 

 

5. Check DPFlex's inputs. 
For details, see “Viewing DPFlex Inputs” on page 65 

 

6. Configure thresholds and check for faults. 
For details, see “Viewing and Configuring Faults” on page 66 

 

7. Save the application parameters and deploy them to other DPFlex controllers. 
For details, see “Deploying DPFlex Applications” on page 68 
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Using DP.D 
You use Agile Systems' DP.D application for Microsoft Windows 2000/XP to develop and 
deploy DPFlex applications. 
 
For details about installing DP.D, see “Installing the Software” on page 26
 
For more information about using DP.D, see the upcoming topics: 

About DP.D 

DP.D enables you to perform the following tasks: 
• Configure DPFlex for a motor. 
• Tune the current and velocity loops for your application. 
• Configure thresholds and view faults: over temperature, over current, and over voltage. 
• Monitor DPFlex inputs. 
• Save configuration parameters to a file on the PC and to DPFlex's non-volatile 

memory. 
• Create, save, and open sets of DPFlex configurations. 

 
To start DP.D : On your Windows Desktop, choose Start > Programs > Agile Systems > DP.D. 

 
To exit  DP.D : In DP.D, choose File > Exit. 

 

Using the DP.D Navigation Tree 

When you start DP.D, it opens a navigation tree that you use to create and manage 
multiple DPFlex configurations. 
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Figure 5-1. The DP.D navigation tree, showing two configurations 

 
DP.D displays each DPFlex configuration as a branch in the navigation tree. It displays the 
parameters for each configuration as leaves on the branch. 
 
Each DPFlex configuration shows which port the controller is connected to, and provides 
access to the following configuration parameters: 
 
• The Stimulus Tools forms enable you to vary motor current or velocity. 

• The Motor parameters form enables you to set motor ratings and command DPFlex to 
configure itself for that motor. 

• The Current Compensator form enables you to define the gains for the application's 
current loop, and provides access to DPFlex's current loop tuning tools. 

• The Velocity Compensator form enables you to define the gains for the application's 
velocity loop, and provides access to DPFlex's velocity loop tuning tools. 

• The Inputs form enables you to view the current values of DPFlex's digital and analog 
inputs. 
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• The Faults form enables you to configure and view fault settings, states, warnings, 
and error messages. 

• The Registers form enables you to store and retrieve DPFlex settings in files, and to 
save those settings to DPFlex's non-volatile memory. It also enables you to configure 
the drive autostart mode. 

 
For details, see the upcoming procedures: 
 
To open a parameters form 
 
• Take one of the following steps: 

o Right-click the desired parameters leaf in the navigation tree and choose Interact. 
o Double-click the leaf. 
 
DP.D displays the form. 

 
To view a configuration's system properties 
 
• Take one of the following steps: 

o Right-click the DPFlex ( Port ) leaf in the navigation tree and choose Interact. 
o Double-click the leaf. 
 
DP.D displays the system properties form. 
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The system properties form displays the following controller information: 
• The current supply voltage 
• The firmware version, and its date and time of compilation 
• The drive's current and voltage ratings 

 
To display or hide a configuration's system properties 
• Click Show Details or Hide Details. 
 
To rename a configuration 
• Right-click the DPFlex ( Port ) branch in the navigation tree and choose Rename. 
 
To add, delete, or change the properties of configurations 
• Take one of the following steps: 

o Right-click the System branch in the navigation tree and choose Connection. 
o Double-click the System branch. 

DP.D displays the Interact form, which lists defined connections: 
 

  
 
For details about using this form, see “Creating and Managing Configurations” on page 46
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Using DPFlex's Digital Oscilloscope 

DPFlex features a four-channel digital oscilloscope that enables you to view your 
application's set points and the motor's actual performance. 
 
To display the digital oscilloscope 
• In the Tools menu, choose Oscilloscope. 
• In the Current Compensator form or Velocity Compensator form, choose Tuning 

Tools. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figure 5-2. DPFlex's digital oscilloscope 
 

The digital oscilloscope features the following controls: 
• The tool bar enables you to manage oscilloscope settings, examine captured signals, 

and control the display
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• The signal display traces the signal coming in on each channel after the trigger 
occurs and for the selected time base. 

• The channel controls enable you to assign a signal to a channel. 
• The trigger type controls enable you to select the type of triggering to use. 
• The time base control enable you to specify the time base used in the display 
• The datalog controls enable you to specify the rate at which inputs are logged and 

the number of data points to plot. 
• The trigger settings enable you to specify the timing and type of trigger. 
• The cursor position indicators show the coordinates of the current cursor position. 
 
For details on using the oscilloscope, see the following procedures: 
 
To use the tool bar 
• Clicking on buttons in the tool bar to perform the actions listed in the table below. 
 

Table 5-1. Oscilloscope tool bar buttons 
Choose this button... ... to perform this action 

 Open an oscilloscope configuration. 

 Save the current oscilloscope configuration. 

 Print the captured data points. 

 Copy all captured data points to the clipboard. 

 Display inputs as graphs. 

 Display inputs in a table. 

 Display scaled data. 

 Position the cursor on the selected input. 

 Zoom out on the graph to show all captured data points. 
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Table 5-1. Oscilloscope tool bar buttons (continued) 
Choose this button... ... to perform this action 

 Zoom in on the selected segment of the graph. 

 Zoom out of the selected segment of the graph. 

 Rescale the display to the input signals' range. 

 Show or hide the cursor. 

 
To view or change a channel's settings 

 

1. Choose the channel's settings button. 

 

     
Channel settings button 

DP.D displays the channel settings form: 

 

 
 

2. Choose Axis to log data or None to disable logging. 

3. Choose the data to log from the list in the Axis Register To Log panel. 

4. Choose OK to save the settings or Cancel to abort the operation. 
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To change the oscilloscope display 

• Take the following actions: 

 

To take this action... ... choose this tool bar button 

Display inputs as graphs.  
Display inputs in a table.  
Display scaled data.  
Position the cursor on the select the input channel.  

Zoom out to show all captured data points.  
Zoom in on the selected segment of the graph.  
Zoom out of the selected segment of the graph.  
Rescale the display to the input signals' range.  
Show or hide the cursor.  

 

 To manage captured data 

• Take the following actions: 

 

To take this action... ... choose this tool bar button 

Open an oscilloscope configuration.  

Save the current oscilloscope configuration.  
Print the captured data points.  

Copy all captured data points to the clipboard.  

 

To select the trigger type 

• Choose one of the following commands: 

• Choose Manual to trigger input logging once immediately. 

• Choose Single to trigger input logging once at the point set with the trigger 
settings controls. 
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• Choose Auto to enable the oscilloscope to trigger continuously and display 
captured data. 

 

To set the time base 
• Using the mouse, rotate the time base control to the desired period. 
 
To set the data logging frequency 
• In the Datalog Rate field, enter the sampling period in seconds. 
• In the Datalog Points field, enter the number of points to log during the time base 

period. 
 
To change the trigger settings 
• In the Trigger Settings area, choose one of the following triggers from the drop-down list: 
 

Choose this setting... ... to set this trigger 

No Auto Trigger ... None. 

On Stimulus Edge ... On the edge of the current or velocity stimulus 

On +ve Stimulus Edge ... On the positive edge of the current or velocity stimulus 

On -ve Stimulus Edge ... On the negative edge of the current or velocity stimulus 

On Enable ... When the motor is enabled 

 
• In the Trigger Settings area, set the point in time to trigger by rotating the Position at % 

of 50 ms control or entering a value in milliseconds in the field below. 
 

Managing Views 

DP.D provides several options for managing its display: 
• You can set DP.D to always display DP.D forms on top of other application windows and 

forms. 
• If you have multiple parameter forms open, you can save their current display positions 

and restore them to those positions after closing the forms or re-starting DP.D. 
• You can set whether DP.D displays a status bar. 
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To toggle displaying DP.D forms on top 
• Choose View > Always on Top. 
To save the currently displayed forms' positions 
• Choose View > Save Windows. 
To restore forms to their displayed positions 
• Choose View > Restore Windows. 
To toggle display of the status bar 
• Choose View > Status Bar. 

 

Getting Help 

DP.D provides online help for all procedures and forms. 
 
To display online help 
• Right-click a node in the navigation tree and choose Help. 
• Choose Help > DP.D Help Topics. 
• Press the F1 key. 
 
To view information about DP.D 
• Choose Help > About DP.D. 

DP.D displays the About DP.D form: 
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Creating and Managing Configurations 
A configuration stores controller and motor settings, and other application parameters. 
DP.D enables you to create and store multiple configurations. 
 
For details, see the upcoming procedures: 

 
To create a configuration 

1. Start DP.D 

a. Click Start > Programs > Agile Systems > DP.D 

DP.D opens the navigation tree: 
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2. Create a new configuration. 

a. In the navigation tree, double-click System. 

DP.D displays the Interact form, which lists defined connections: 

 

b. Choose Add. 

DP.D displays the Connection Info form. 

c. If the port to which the DPFlex controller is connected is not displayed in the Port 
drop-down list, choose Scan Ports. 

DP.D scans the PC for serial ports or the USB-to-serial adapter. 

d. If the USB port does not appear in the list, check the following items and re-
scan: 

• That the USB-to-serial driver is installed 

• That the USB-to-serial cables are properly connected 

e. In the Port drop-down list, choose the port to which the DPFlex controller is connected. 

 

f. Choose Test to confirm the connection to the controller is working. 
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g. If the test fails, check the following items and re-test: 

• That the communication cables are properly connected 

• That the DPFlex controller is powered 

h. Choose OK to accept the connection or Cancel to abort the operation. 

The Interact form now lists the connection to the controller: 

 
 

i. Choose OK to accept the controller connection configuration or Cancel to 
abort the operation. 

DP.D updates the navigation tree for the new configuration: 

 
  

To save the current configurations 

1. Choose File > Save. 
If you have not previously saved the configurations, DP.D displays a browser. 

2. Select a path and file name for the configurations and choose Save. 
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To save the current configurations to a different file 

1. Choose File > Save As. 

DP.D displays a browser. 
 

2. Select a path and file name for the configurations and choose Save. 

 

To create a new set of configurations 

1. Choose File > New. 

If you have not previously saved the current configurations, DP.D prompts you to save 
or discard them. 
 

2. If you want to save the current configurations: 

a. Choose Yes. 

DP.D displays a browser. 

b. Select a path and file name for the configurations and choose Save. 
 

3. If you want to discard the current configurations, choose No. 

4. If you want to cancel the creation of the new configurations, choose Cancel. 

 
To open a set of configurations 

1. Choose File > Open. 
DP.D displays a browser. 

 

2. Select a path and file name for the configurations and choose Open. 
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Configuring DPFlex 
You configure DPFlex by setting motor parameters and running the configuration tool. 
After the tool has finished, you can save the configuration parameters to the controller's 
non-volatile memory so that they are not lost if the controller loses power. 
 
For details, see the following procedures: 
 

To set motor parameters 

 
1. In the DP.D navigation tree, double-click System > DPFlex ( Port ) > Motor . 

DP.D displays the Motor parameters form: 
 

 
 

2. From the motor's data sheet, set the following parameters: 
 

To set this parameter... ... take this action 

Number of Pole Pairs Enter the number of pairs. 

Motor Peak Current Enter the number of Amperes. 
 

3. Choose Apply to update the motor parameters. 
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To run the configuration tool 
1. In the Motor parameters form, choose Start. 

The DP.D configuration tool displays the configuration instructions: 
 

 
 
 

CAUTION Failure to ensure that the motor is fixed in place, not connected to a 
load, and that the shaft can turn freely may result in improper configuration and 
damage to equipment or personnel. 

 
 
 

2. Choose Continue to start the configuration operation. 
Choose Stop at any time to immediately halt the configuration operation. 

 
3. Follow the instructions in the configuration tool to complete the configuration. 

Note The configuration operation can take several minutes to complete. 
 

4. Click  to close the configuration tool. 
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To save configuration parameters to DPFlex's non-volatile memory 
1. In the DP.D navigation tree, double-click System > DPFlex ( Port ) > Registers. 

DP.D displays the Registers form: 
 

 
 

2. Choose Update Registers. 
DP.D saves the current configuration parameters into the drive's non-volatile memory. 

 

3. Click  to close the Registers form. 
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Tuning the Current Loop 
Once you have configured DPFlex for the target motor, you can tune the current loop for 
the application. 
 
A well-tuned current loop is the first step to acceptable velocity and torque control. Without 
proper current tuning, satisfactory velocity and torque control cannot be achieved.  
 

Current Compensator Loop 

The current loop is a control loop inside the velocity loop, which makes sure the desired current 
setpoint will be achieved and maintained. Refer to the block diagram shown in Figure 5-3 below. 
Except for the plant (the motor and its load), all of the blocks are parts of the drive. For the sake of 
simplicity, the plant is just an R-L transfer function of a BLDC motor. In the control loops, two main 
tasks must be achieved: 

• Keeping the output (in this case, current in the motor coil) as close as possible to the 
input (in this case, a current setpoint). This is called steady state response . 

• Proper response to the change in the setpoint. This is called dynamic response . 
 
To achieve these two goals, a second order infinite impulse response filter (biquad compensator) is 
used to approximate a classic PID control loop. 
  

 
Figure 5-3. Current loop block diagram 
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BiQuad Compensator 

A classic PID control loop can be approximated in the discrete time domain by a 2nd order 
IIR filter with the following (z) domain transfer function. 

(1) 

Which has a block diagram: 

  

Figure 5-4. Biquad filter structure 

Calculating Filter Coefficients 

DP.D automatically calculates the biquad filter coefficients (Bn and An ) from the on screen 
representation (gains Kp, Ki, and Kd). BiQuad coefficients are values described in Q1.15 
format with exponent value. Many good digital signal-processing texts contain a 
description of the Q1.15 numerical format. 
The transfer function of the PID compensator in the (s) domain is  

(2) 

To find out how PID gains are related to BiQuad gains, let's assume that , which is 
an approximation of the bilinear transformation. Then, by substituting (z) in (2): 

 (3) 
 and by comparing (1) and (3): 

 (4) 

 (5) 
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(6) 

(7) 

(8) 
 
Equations 4 through 8 show how each of the 5-biquad filter coefficients are calculated from 
the screen PID representation in DP.D. 

 
To tune the current loop 
1. Make sure the motor shaft is connected to the required load, that the load is free to 

move and can move safely, and that the motor itself will not move when turning. 
 

CAUTION You risk damaging equipment or personnel during tuning if you do not 
ensure that the load can move safely and that the motor will not move when rotating! 

 
 

2. In DP.D's navigation tree, double-click System > DPFlex ( Port ) > Current Compensator. 
DP.D displays the Current Compensator form: 
 

 
 
The Current Compensator form displays the current gains set for the target motor. It  
also enables you to re-calculate the gains based on the motor parameters and to open 
DP.D's tuning tools. 
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3. Choose Tuning Tools. 
DP.D displays the Oscilloscope and the Current stimulus forms: 
 

 
 
|Tip You can arrange the forms as you like and save their positions using the View > 
Save Windows command. You can restore the forms to their saved positions at any 
time (including the next time you run DP.D) with the View > Restore Windows 
command. 
DP.D automatically sets the controls and fields in the Oscilloscope and Current 
stimulus forms to default values appropriate for tuning the current loop, based on the 
values you set in the Motor parameters form. 
The Current stimulus form enables you to vary the current available to the motor: 
 
 

 

Pulse amplitude sliders 
 
 
 
 
Pulse frequency slider 
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• The Rated Current field shows the maximum current available from the DPFlex drive. 

• The Motor Peak Current field shows the value previously set for the motor's peak current 
rating. (To change this value, see “To set motor parameters” on page 50) 

• The Control Mode section enables you to set Current or Torque as the control mode. 

• The Stop/Start control enables you to turn the current to the motor on or off. 

• The current controls enable you to set the following characteristics: 

• The DC command sets the current to direct. 

• The Pulse command sets the current to a square wave. 

• The Frequency field and slider sets the frequency of the square wave. 

• The Maximum and Minimum fields and sliders set the maximum and minimum values 
of the current pulse as percentages of the motor peak current. These values can be 
negative, zero, or positive. 

 

4. In the Current stimulus form: 

a. Choose Current Mode. 

b. Choose Pulse. 

c. Set the desired values for current pulse frequency and amplitude. 
 

5. In the Current stimulus form, choose Start to apply current to the motor. 

6. In the Oscilloscope form, choose Auto to start triggering. 

After a few seconds, the Oscilloscope form will display the current stimulus in green and the 
actual current drawn by the motor in red: 
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You can vary the settings in the Current stimulus form, including the slider controls for 
the frequency and amplitude of the current stimulus, to see how it affects the current 
the motor draws. 
 

7. In the Oscilloscope form, choose Auto to stop triggering. 
 
8. In the Current stimulus form, choose Stop to cut current to the motor. 
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Tuning the Velocity Loop 
Once you have configured DPFlex for the target motor, you can tune the velocity loop for 
the application. 
 

Velocity Compensator Loop 

The velocity loop makes sure the desired velocity setpoint will be achieved and 
maintained. Refer to the block diagram in Figure 5-5 below. Except for the plant (a motor 
and its load), all of the blocks are parts of the drive. For the sake of simplicity, the plant is 
just an R-L transfer function of a DC motor. In the control loops, two main tasks must be 
achieved: 
 
• Keeping the output (in this case, velocity of the motor) as close as possible to the input 

(in this case, a velocity setpoint). This is called steady state response . 
• Proper response to the change in the setpoint. This is called dynamic response . 
 
To achieve these two goals, a second order infinite impulse response filter (biquad 
compensator) is used to approximate a classic PID control loop. 
  
 

 
Figure 5-5. Velocity loop block diagram 
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BiQuad Compensator 

A classic PID control loop can be approximated in the discrete time domain by a 2nd order 
IIR filter with the following (z) domain transfer function. 

(1) 

Which has a block diagram: 

  

Figure 5-6. Biquad filter structure 

Calculating Filter Coefficients 

DP.D automatically calculates the biquad filter coefficients (Bn and An ) from the on screen 
representation (gains Kp, Ki, and Kd). BiQuad coefficients are values described in Q1.15 
format with exponent value. Many good digital signal-processing texts contain a 
description of the Q1.15 numerical format. 
The transfer function of the PID compensator in the (s) domain is  

(2) 

To find out how PID gains are related to BiQuad gains, let's assume that , which is 
an approximation of the bilinear transformation. Then, by substituting (z) in (2): 

 (3) 
 and by comparing (1) and (3): 

 (4) 

 (5) 
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(6) 

(7) 

(8) 
 
Equations 4 through 8 show how each of the 5-biquad filter coefficients are calculated from 
the screen PID representation in DP.D. 

 
To tune the velocity loop 
1. Make sure the motor shaft is connected to the required load, that the load is free to 

move and can move safely, and that the motor itself will not move when turning. 
 

CAUTION You risk damaging equipment or personnel during tuning if you do not 
ensure that the load can move safely and that the motor will not move when rotating! 

 
 

2. In DP.D's navigation tree, double-click System > DPFlex ( Port ) > Velocity Compensator. 
DP.D displays the Velocity Compensator form: 
 

 
 
The Velocity Compensator form displays the current gains set for the target motor. It  
also enables you to re-calculate the gains based on the motor parameters and to open 
DP.D's tuning tools. 
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3. Choose Tuning Tools. 
DP.D displays the Oscilloscope and the Velocity stimulus forms: 
 

 
 
Tip You can arrange the forms as you like and save their positions using the View > 
Save Windows command. You can restore the forms to their saved positions at any 
time (including the next time you run DP.D) with the View > Restore Windows 
command. 
Note DP.D automatically sets the controls and fields in the Oscilloscope and Velocity 
stimulus forms to default values appropriate for tuning the velocity loop. 
 
The Velocity stimulus form enables you to vary the velocity stimulus to the motor: 
 
 

 

Pulse amplitude sliders 
 
 
 
 
Pulse frequency slider 
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To do this... ... take this action 

Set the starting current. In Starting Current, enter the starting current in  
Amps. The starting current is the current needed to 
move the motor from an a standing still position. This 
current has to be sufficient to generate enough torque 
to overcome the static inertia of the motor plus the 
load. 

Set the maximum velocity. In Maximum Velocity, enter the maximum 
permitted velocity in revolutions/minute. 

Control the velocity from DP.D. In Control Mode, choose Host. 

Control the velocity from an 
external analog input. 

In Control Mode, choose Analog Input. 

Set the type of stimulus. Choose DC for a constant velocity stimulus or 
Pulse for a varying velocity stimulus. 

Set the range of the velocity 
pulse stimulus. 

In the Maximum and Minimum fields or using their 
matching sliders, enter the maximum and minimum 
velocity pulse stimulus to percentages of the value 
you set in Maximum Velocity. 

Set the frequency of the velocity 
pulse stimulus. 

In the Frequency field or using the matching slider, 
enter the frequency of the velocity pulse stimulus. 

Start or stop the motor. Choose Start or Stop. 

  
4. In the Velocity stimulus form: 

a. Choose Pulse. 
b. Set the desired values for starting current, maximum velocity, maximum and 

minimum velocity setpoints, and velocity pulse stimulus frequency. 
 

5. In the Velocity stimulus form, choose Start to apply the velocity setpoints to the motor. 
6. In the Oscilloscope form, choose Auto to start triggering. 
 

After a few seconds, the Oscilloscope form will display the velocity stimulus setpoints 
and the actual velocity of the motor. 
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You can vary the settings in the Velocity stimulus form to see how it affects the actual 
velocity achieved by the motor. 

 
7. In the Oscilloscope form, choose Auto to stop triggering. 
 
8. In the Velocity stimulus form, choose Stop to stop the motor. 
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Viewing DPFlex Inputs 
When DPFlex is connected to a PC, you can use DP.D to check the signals at the input pins. 
 
Note While you are checking the inputs with DP.D, the drive is disabled. 
 
To monitor DPFlex inputs 
1. In DP.D's navigation tree, double-click Inputs. 

 
DP.D displays the Inputs form: 

 

 
 

The Digital Input One and Digital Input Two indicators turns ON when signal voltage is 
applied across the corresponding inputs. The Analog Input One indicator shows the 
percentage of input voltage across the analog input. 

 

2. Click  to close the Inputs form. 
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Viewing and Configuring Faults 
DP.D enables you to view and configure faults while the DPFlex drive is running. 
 
For details, see the upcoming procedures: 

 
To view and configure fault thresholds 
1. In DP.D's navigation tree, double-click Faults. 

DP.D displays the Faults form: 
 

 
 

2. Set the thresholds by entering values for temperature, current, and voltage in degrees 
Celsius, amperes, and volts, respectively. 

 
3. Choose Apply. 

 

4. Click  to close the Faults form. 
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To view the operational status of the drive and motor 
1. In the Faults form, choose the Status tab: 

 

 
 

2. Check the current status: 
• Choose Refresh to update the display with the current status. 

• Choose Clear Faults to clear the display and update the status. 

 

3. Click  to close the Faults form. 
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Deploying DPFlex Applications 
At any time during application development, you can update a connected DPFlex drive's 
non-volatile memory with the current configuration parameters. You can also save DPFlex 
configuration parameters to a file and load these parameters into a connected DPFlex 
drive's non-volatile memory. 
 
You can also define in which mode to run the motor when the drive powers up. 
 
For details, see the following procedures: 
 
To update DPFlex with the current configuration parameters 
1. In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. 

DP.D displays the Registers form: 

 
 
2. Choose Update Registers. 

DP.D saves the current configuration parameters into the drive's non-volatile memory. 
 

3. Click  to close the Registers form. 
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To save configuration parameters to a file 

1. In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. 
DP.D displays the Registers form: 
 

 
 

2. Choose Save Registers. 
DP.D opens a browser. 

 
3. Select the path and file name and choose Save. 

 

4. Click  to close the Registers form. 
 

To load configuration parameters from a file into DPFlex's non-volatile memory 
1. In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. 

DP.D displays the Registers form: 
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2. Choose Load Registers. 
DP.D opens a browser. 

 
3. Select the path and file name and choose Open. 

DP.D loads the parameters into the drive's non-volatile memory. 
 

4. Click  to close the Registers form. 
 

To set the drive to Auto-Start or Start on Enable Input 
1. In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. 

DP.D displays the Registers form: 
 

 
 

2. Select Auto Start or Start on Enable Input from the first drop-down list box. 
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3. Select from one of four motor start-up parameter from the second drop-down list box. 
DP·D displays the motor start-up parameters drop-down list box. 
 

 
 

4. You can choose to start the motor using a torque or velocity set point. You can also 
choose a fixed set point or one set by the analog input. 
 

5. If you chose to use a fixed set point, enter the required set point value in the  
Fixed Velocity or Fixed Torque field. 

  
 

6. If you chose to use a set point set by the analog input, enter the maximum permitted 
set point value in the Maximum Velocity or Maximum Torque field. 

  
 

7. Enter the Starting Current in amperes. 
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8. Choose Update Registers. 

DP.D saves the current configuration parameters into the drive's non-volatile memory. 

9. Click  to close the Registers form. 
 
Note You must cut power to the drive, disconnect it from the computer, and restore power 
to the drive to start using the auto-start function. 
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